w: 警告: 来自注释处理程序 'org.jetbrains.kotlin.kapt3.base.ProcessorWrapper' 的受支持 source 版本 'RELEASE_7' 低于 -source '1.8'


#1

编译代码,出现这个警告,求大神指点一二


#2

找到 1.8 改成 1.7 试试


#3

我也碰到了这个问题


#4

除了降级 有没有别的解决方式


#5

请问这个问题您解决了吗 ?我现在被这个问题困扰了好久,方便的话 加下我的求求 417460460


#6

这就是说你用的apt只支持生成 1.7 的代码,但你用的是 1.8。目前看也没什么大不了的,让apt的开发者去升级版本,或者你降级 :sunglasses:


京ICP备16022265号-2 Kotlin China 2017 - 2018
本站由腾讯云提供计算服务