kotlin怎么解决gradle控制台输出中文乱码的问题?


#1


#2

AndroidStudio有同样的问题。。。。


#3

我也想知道


#4

我试了一下,不会乱码,你看看是不是你的IDE的编码问题

image


#5

Help -> Edit Custom VM Options…
输入 :-Dfile.encoding=UTF-8
image
image

编辑完之后记得重启一下 :wink:


#6

这样虽然能解决,但是我想在gradle中配置JVM字符集怎么办?
我试试
tasks{ withType<KotlinCompile> { kotlinOptions { freeCompilerArgs = listOf("-Xjsr305=strict“,"-Dfile.encoding=UTF-8") jvmTarget = "1.8" } withType<JavaCompile> { options.encoding = "UTF-8" } } }
并没有起作用


京ICP备16022265号-2 Kotlin China 2017 - 2018